I cannot install the current version of the locr GPS Photo software.
The Download was ok, but during the installation an error message appears, informing you that a former version of the locr GPS Photo software is installed on your PC?

In this case you have to delete the ´old´ version first. That´s easy: